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E2-Studio Integration – Getting Started Guide 
Using Renesas RA6T2 Flexible Motor Control Kit  

Description 

This document covers the development and testing of the Finger Friction demo using Renesas’s RA6T2 kit & 
Reality AI Tools portal. The portal is useful to generate AI models for non-visual sensing applications.  

This document contains the following sections: 

Lab Section Demo Steps 

Section 1 Prerequisites  

Section 2 Data Collection 

Section 3 Model Generation 

Section 4 Testing the Models 

Section 5 Appendix 

Sections should be followed sequentially. 

 

Lab Objectives 

• Gain hands-on 

experience on developing 

a simple AI demo using 

Renesas RA6T2 motor kit 

+ Reality AI Tools. 

Lab Materials 

• Please verify you have the following materials at your lab 

station. 

o PC with Windows 11. 

o Project files provided by Renesas - Reality AI 

team (link in section 1 of the document).  
o E2-Studio IDE v4.6 (link in section 1 of the 

document). 

o Reality AI Tools Account 
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1 Prerequisites 

Overview 

This section covers the prerequisites for running the finger friction demo. 

Procedural Steps 

 This lab requires the RA6T2 Flexible Motor Control Kit. 

  

The MCK-RA6T2 kit comes with: 

1. RA6T2 board 

2. DC brushless motor by moon industries.  

3. Communications board (not used in this demo) 
4. Necessary USB cables 

Link: https://www.renesas.com/us/en/products/microcontrollers-microprocessors/ra-cortex-m-
mcus/rtk0ema270s00020bj-mck-ra6t2-renesas-flexible-motor-control-kit-ra6t2-mcu-group 

Additional components: 

1. 36 V power supply (recommended but not required. Amazon link ). 

2. USB to UART cable (Amazon link) -- required. (or alternate) 

Assemble the kit as shown in the next section. 

https://www.renesas.com/us/en/products/microcontrollers-microprocessors/ra-cortex-m-mcus/rtk0ema270s00020bj-mck-ra6t2-renesas-flexible-motor-control-kit-ra6t2-mcu-group
https://www.renesas.com/us/en/products/microcontrollers-microprocessors/ra-cortex-m-mcus/rtk0ema270s00020bj-mck-ra6t2-renesas-flexible-motor-control-kit-ra6t2-mcu-group
https://www.amazon.com/ALITOVE-100-240V-Converter-Transformer-Engraver/dp/B07WNST3BG/ref=sr_1_3?keywords=36+volt+power+supply&qid=1693575987&sprefix=36+volt+power%2Caps%2C151&sr=8-3
https://www.amazon.com/dp/B07RBKCW3S?ref=ppx_yo2ov_dt_b_product_details&th=1
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 Assemble the kit as shown below. Make sure the toggle switch is in the OFF position.  All other jumpers in 
their default condition.  Reference the documentation that came with the kit if there is concern that the 
board may not be in the default configuration. 

1. Connect the PC to USB-C on the board 

2. Connect the external power supply (optional). 

3. Connect the USB to UART (CN10).  (see diagram below for pinning of the UART to USB) 

4. Connect the motor to CN2. 

 

Pin reference: 

Pin[4]-> VCC  (no connection)        
Pin[3]-> TX    to RX (Green wire) 
Pin[2]->RX     to TX (White wire) 
Pin[1]->GND  to GND (Black wire) 

 

 
This lab requires Renesas E2-Studio IDE 2023-07 or newer with FSP 4.6 or newer (till FSP 5.2). 

Platform installer available here: Link Take note of where e2studio is installed. 

 

https://github.com/renesas/fsp/releases/download/v4.6.0/setup_fsp_v4_6_0_e2s_v2023-07.exe
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This lab requires modification to the eclipse configuration file if FSP 4.6 is used. For later versions, skip 
this step. 
 
Navigate to E2 studio installation directory (install folder) --> e2_studio --> eclipse --> configuration --> 
open file: config.ini  (installation folder may be different) 

 

Copy the following line: com.renesas.realityAi.apiBase=https\://portal.reality.ai/api 

And paste it at the end of the file: 

 

This line ensures that e2 studio will connect to Reality AI server for data upload and model training. Be 
sure to save the config file before closing. Restart e2studio if it is currently running. 

https://realityai.slack.com/portal.reality.ai/api
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 This lab requires an account on the Reality AI website. 

Login to Reality Tools (https://portal.reality.ai/login) using the username and password provided. Reach 
out to Renesas – Reality AI team members if you need credentials + instruction documents for the portal. 

 

 

Leave the browser open in the background. 

  

  

https://preprod.reality.ai/login
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2 Data Collection 

Overview 

This section covers collecting data with the Reality-AI eclipse plugin using e2studios. 

Procedural Steps 

 Open E2 Studio IDE and select a workspace. Although the workspace can be in any folder, this lab 
assumes the workspace shown below.  c:\e2_projects_4.6 

 

 
Go to File → Import... Then choose General->Existing Projects into Workspace 

 

Click Next to continue. 
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Check “Select archive file” and navigate to the zip file for this lab. This lab contains one project.  Make 
sure it is selected and then click Finish. 

 

The demo project is imported into the workspace 

 Return to the Reality-AI tool and start a new project.  Click on +Add Project, give the project a name and, 
optionally, a description.  Then click the +Add Project button in the lower right. 
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 Navigate to the username on the top-right of the screen and select API Key Option. 

 

 Copy this API key to the clipboard. This key will be used to connect e2 studio IDE and Reality AI Tools.  

 

 
Open e2 studio and navigate to Renesas AI --> Reality AI Authentication 
(note: If Renesas AI does not appear in the menu, consult the appendix) 

 
Paste the API key and click Apply and Close 

 
The IDE can now connect to the Reality AI site 
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Navigate to Renesas AI --> Show View --> Reality AI Data Storage Tool 

 
A new window will open in the bottom pane. Click-and-drag the view to the main view area by clicking on 
the tab and drag-drop in the tab area of the main view. Select the project in the pulldown, then click on 
“Data Connection" button. 

 
 

 
In the menu that pops up, select the COM port, baudrate (115200), and communication protocol parameters 

(8-N-1). Then press Connect --> then press Close. 
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Once connected, the status (top left) should show “Receiving data...” with a check mark. 
Note: the green check mark indicates that the connection is successful. Not that it is receiving data yet. 

 
 

 
Expand the project in the Project Explorer view and open hal_entry.c. Verify/change USE_SHIPPER to be 
defined as 1. This will build the project in the data collection mode. 

 
Save the file and build the project by clicking the hammer icon 

 
The project should build without error. There will be some warnings, these are expected. 

 



 
 

 
Reality AI Tools Tutorial Pagé 13 of 34   
© 2024 Renesas Electronics. All rights reserved.  Download and disclosure restricted by Reality AI Tools® Terms & Conditions. 

 
Make sure the toggle switch is in the OFF position. Start a debug session by clicking the Debug Icon in the 
toolbar 

 
Click “Allow access” if you get a warning from Windows Defender. Check the “Remember my decision” 
checkbox and click Switch if the following dialog appears. 

 
 

 
Click the Resume button twice. The program is now running 

 
Switch the toggle switch to the ON position. The motor should now be running. 
 

 
WARNING: Never stop the debugger while the motor is running.  This will cause commutation to stop, 
possibly leaving a coil energized.  This will cause the motor to get very hot.  If the motor is not spinning at 
this stage check the connections and review the material above. 

 Click on the “Reality AI Data Storage Tool” view and verify the presence of a wave form in the Signal view. 
If there is nothing showing, click File review and then Live view (highlighted below). If there is still no 
waveform, recheck the prerequisite steps to make sure the connections are correct. 

 



 
 

 
Reality AI Tools Tutorial Pagé 14 of 34   
© 2024 Renesas Electronics. All rights reserved.  Download and disclosure restricted by Reality AI Tools® Terms & Conditions. 

 Click on the Data file settings and verify CVS file and Output folder. The Output folder is relative to the 
project. Click OK to close the dialog. 

 

 Note that the Data Storage tool reflects the data in the project’s Output folder. The data currently there 
was collected during the lab development and includes date and time information. New data will be 
collected in the following sections. 

 

 
There are two methods to collect data: Number of frames per file and Unlimited. If the user selects 
Unlimited (by checking the Unlimited checkbox) data collection will occur until the user manually stops 
the collection process. Otherwise (Unlimited box unchecked) the collection will automatically stop once 
the Number of frames per file is reached. For this project, setting the Number of frames per file to 200 
results in approximately 52 seconds of data. The remainder of this lab assumes Unlimited capture 
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In the Reality AI Data Storage Tool, check the Unlimited checkbox. Enter the Class name “friction.” While 
applying and maintaining slight friction to the motor shaft, Click the “Start new Capture” button. The 
button text will change to “Stop Capture.” Maintain friction for 45 to 60 seconds and then click the Stop 
Capture button. 

 
45 to 60 second's elapses... 

 
A new data file appears in the output folder 

 

 
Change the Class name to “normal” and repeat the above steps without applying friction 
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 This concludes the data capture portion. 

Turn the toggle switch off to stop the motor! 

Click the red square icon to terminate the debug session. 

 

(If you do not see the terminate icon, select the Debug perspective in the upper right corner) 

 Follow these steps to upload the data files collected in the last section: 

1. Select the two files using click + ctrl-clik 

2. Scroll the view to expose the Upload... button 

3. Click the Upload... button 
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 A dialog box should appear with the projects currently defined on the Reality AI website. 

(if there are no projects in the pulldown, verify the changes made to the config.ini file, regenerate an API key and 
restart e2studios) 

 

Select the Finger Friction Demo  (or whatever the project was named in the prior step) 

Set the Sampling rate to 1000 and press OK 

 

The data files, along with the metadata.csv file will upload, and a confirmation dialog should appear. 

 You have finished this section. 
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3 Creating Models 

Overview 

This section covers creating AI models on the collected dataset. A Reality AI Tools account is required. 

Procedural Steps 

 If not already logged in to Reaity AI Tools, use this link: https://portal.reality.ai/login with the provided 
password. Reach out to Renesas – Reality AI team members for credentials + instructions documents 
for the portal if needed. 

 Format the data. Click on the Finger Friction Demo project to set active.  

 

Click on the Data tab on the left to expand and follow these steps: 

1. Click on Curate. 

2. Click on Source Files to expand. 

3. Check box next to File Name to select all files 

4. Click on the Action button. 

5. Click on Format Selected 

 

This opens a dialog box. 
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Follow these steps: 

1. Click on Data to expand the drop down 

2. Use the scroll bar to scroll down (or mouse wheel) 

 
3. Select Ignore (this column is not part of the data) 

 
4. Click confirm 
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Verify that the data shape is now 1 X {num of samples} and the Sample rate is 1000Hz 

 

 
Preprocess/segment the data files. Click the Action button and select *** Segment List from Selected 

 

 
Why Segmentation? 

 
One of the main purposes of generating models from Tools is to deploy them to a variety of Renesas 
MCU’s. To that effect, these models must process live data within a resource constrained environment. 
So, for practical purposes, a model might be looking at 1 second, 500 ms, or even a smaller window 
length to make quick predictions on Realtime data. As opposed to a few seconds (or minutes or hours) 
long data stream. To mimic that effect, we break down the raw training data and feed that to the 
model generation engine to start learning what it is going to see in a live (production) setting.  
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 Assign window length, overlap, and provide name to the list. Follow these steps: 

1. Set Window Length to 256 
2. Click the 50% button to select a 50% offset 
3. Give the list a meaningful name 
4. Click Submit 

 

The number of estimated samples will be dependent on the amount of data collected. So if your 
estimated samples don’t match the below screenshot, its still okay. 

Window Length: The window length determines how much data will be considered by the AI to decide 
on a classification. 

Offset: The offset determines how far ahead from the start of the last window the parser moves before 
creating a new window.  

General Guide: 50% Overlap is usually a good compromise between covering starting-point variations 
in the data and too much redundancy. 

 Use non-overlapping windows when you have a great deal of data, with longer offsets. Typically, users 
will do initial exploration and training on a subset of the available data.  

Use All Shifts (offset = 1) for testing after you have a suitable candidate classifier, and you want to 
simulate performance on a stream of new data arbitrarily sampled. 
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 After successfully creating the segmented list, navigate to AI Explore → Classes 

 

 
Reality AI Tools has options for creating 3 types of AI Models:  
 
Classes: When there is labeled categorical data (option used in the tutorial). You might have noticed 
that we uploaded perfectly labeled data in section 1. This is needed for classification models as 
supervised learning is being performed.  
Values: When discrete int or float values are used instead of categories. (Example: What is the exact 
temperature of a machine? Or What is the exact value of tire pressure of a car?). This is also supervised 
learning.  
Anomalies: This is an Anomaly Detection module. It is a semi-supervised model where the user only 
needs examples of Normal data to create a baseline model.  

 Click on the newly created list and then click on “Start Exploring” to start the feature discovery and 
model training process.  
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 Once the explore finishes, select the highest performing model (we recommend model with feature 
space: Spectral Magnitude) and click on the Create Base Tool button. Hover over each Explanation to 
get more information about the model.  

 

 
What is happening in the background: 
 
Clicking on the Start Explore button will turn the Reality AI algorithm loose on your data. It will create 
several optimized feature sets and machine learning models that best fit the classification problem and 
then summarize each model’s accuracy and resource consumption. 
 
What is the algorithm doing: AI Explore first creates a balanced subset of the sample list (meaning a 
list in which each class has equal numbers). If the sample list is exceptionally large, it may also sub-
sample for a shorter processing time. Explore then runs through a procedure in which the Reality AI 
algorithms attempt to discover the best possible set of features and machine learning parameters for 
separating the different training classes represented in the data. The feature sets that are most 
promising are then used to construct machine learning models, which are trained on the sub-sample 
and put through a K-Fold validation.  
 
Only the best performing results are displayed. Several hundred different feature sets and machine 
learning models are compared in a typical AI Explore run.  
 
What is K-Fold validation: K-Fold is where a given data set is split into a K number of sections/folds 
where each fold is used as a testing set at some point. Let us take the scenario of 10-Fold cross 
validation(K=10). Here, the data set is split into 10 folds. In the first iteration, the first fold is used to 
test the model and the rest are used to train the model. In the second iteration, the 2nd fold is used as 
the testing set while the rest serves as the training set. This process is repeated until each fold of the 10 
folds has been used as the testing set. We use K=10 in the AI Explore page.  
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 Provide a name or use the one suggested.  Click Add.  

 

The icon will change, indicating the base tool has been created. 
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 Now that the model is ready to be deployed, Follow these steps to produce a new package. 

1. Click on Deploy->Embedded. 
2. Click on the Trained Tool Description list 
3. Click on + New Package 

 

  

 Set the options as indicated.  The deployed name should be finger_friction_combined to match the 
code in e2studios.  Choosing another name will require additional edits to the code. 

 

The package will take a few minutes to generate. 
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 It will take ~10-15 minutes for the model to be available for download. Once ready, download the zip 
file using the highlighted button. 

 

 There are 7 files in the downloaded archive. Copy and paste all files except example_main.c & 
readme.txt to the src directory of the E2-Studio project workspace (src --> models->how_to), 
overwriting the current files. 

Note: file names may be different depending on the project name assigned in tools.  

In the files below, the model function call is specified in finger_friction_combined_model.h.  

 

 You have finished this section. 



 
 

 
Reality AI Tools Tutorial Pagé 27 of 34   
© 2024 Renesas Electronics. All rights reserved.  Download and disclosure restricted by Reality AI Tools® Terms & Conditions. 
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4 Deploying the model 

Overview 

This section covers testing the model on hardware. 

Procedural Steps 

 Open hal_entry.c and import the header file. If the deployed model name was 
finger_friction_combined then no changes are required.  Otherwise, edit the #include to the deployed 
model’s header file. 

 

 Modify the following lines of code if the deployed model name was other than 
finger_friction_combined.  Values can be found in the header file included in the last step. 

 

Edit lines above by copying the class names from header file included above. Again, no edits necessary 
if the deployed model name is finger_friction_combined. 
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Change the USE_SHIPPER define to 0.  This will cause the project to build in the test mode. 

 

 Build & debug the project as before. Click on the Resume button twice. Now the board is running on 
inference mode. Turn the motor switch ON and run the motor.  
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 Let the motor run in normal/ balanced mode with no friction. The three LED’s will be OFF (indicated by 
the arrow) during this time. 
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 Apply minor/ light friction. The LED’s should turn on (indicated by the arrow) to indicated friction/ 
unbalanced behavior.  

 

 What should I do if model is not performing well? 

Collect some more data and retrain the model. Usually additional data collection helps in creating 
better performing models across different conditions.  

Double check if the data collection method and testing method are the same. For example: Are you 
collecting unbalanced data by applying high friction to the motor shaft by testing it by applying low 
friction? In that case, performance may be inconsistent. Collecting more data across these variations 
should help. 

 
Warning: Be to turn the toggle switch off before stopping the debugger. 

 You have finished this section. 
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5 Appendix 

Overview 

If the Reality AI items do not appear in the title bar perform the following steps. 

Procedural Steps 

 
Click on Help -> Install Renesas IDE Features... 

 

 
Select the Reality-AI features and click Finish. 
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Restart e2studios when prompted. 

 
You have finished this section. 

 
 

END OF LAB 
THANK YOU 
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